Network Anomalies

Si.

Si.

Associate
Joined
22 Oct 2002
Posts
2,473
Location
Melbourne, Aus
I've noticed a strange network bug on my MBP 14"

I have it wired to the network using a Caldigit Dock, I also have WiFi turned on. What I've noticed is that when I first boot the Mac up all is ok and the network traffic uses the wired connection via the Caldigit dock, however when my Mac sleeps and is woken up, ALL network traffic then goes via the Wifi connection, even though the doc is connected and working, and the dock NIC shows as connected and up.

The only way to get it to switch back to wired is to turn off Wifi or Reboot.

Anyone else have this problem?
 
Caporegime
Joined
20 Sep 2006
Posts
28,396
You need to Set Service Order in Network Preferences and make sure the wired is higher in the list than wireless.
 
Commissario
Joined
16 Oct 2002
Posts
335,918
Location
In the radio shack
I wondered that but if it connects via wired first time then it should always do it, surely? The default is for wired to be above wifi.
 
Associate
Joined
3 Jun 2005
Posts
2,130
Location
The South
You need to Set Service Order in Network Preferences and make sure the wired is higher in the list than wireless.

That should work although once in a blue moon, MacOS does have a habit of ignoring the Service Order and prioritising the WiFi connection.

In the past (last time was on Big Sur) i've deployed this script (https://gist.github.com/albertbori/1798d88a93175b9da00b) which disables WiFi when it detects an Ethernet connection.
 
Caporegime
Joined
20 Sep 2006
Posts
28,396
That should work although once in a blue moon, MacOS does have a habit of ignoring the Service Order and prioritising the WiFi connection.

In the past (last time was on Big Sur) i've deployed this script (https://gist.github.com/albertbori/1798d88a93175b9da00b) which disables WiFi when it detects an Ethernet connection.
I must admit I sometimes end up on wireless, I usually just disconnect it from the wifi network which puts it back to wired.
 
Top Bottom