Porsche Owners Thread - If you own one or just like or hate them! :)

Soldato
Joined
18 Oct 2002
Posts
14,756
Location
The land of milk & beans
I need someone to talk some sense in to me. I'm coming to the end of a PCP deal on my E400d and have a decent equity in the car, almost 5 figures. Heart is telling me to go for a 911 and kick off my midlife, but head (and wife) is having doubts.

I'm looking at a similar finance deal over 3 years on a 2014-16 911, ideally a C2/C2S 991.2 to avoid IMS/RMS issues with the 991.1's. Is there anything else I should be looking out for, reliability wise?

My man-maths seems that tyres, insurance is about the same between a C2S and my E400, and road tax on the 911 is actually half of the diesel... go figure. Servicing obviously more costly for the Porsche, but that's to be expected. Would need to find a good specialist.

With the inflated used car market I've got a nagging in my brain saying that a PCP right now is a stupid idea, as the GMFV will be a complete crapshoot... which leads back to the head saying to just get something sensible and downsize as I'm not doing many miles due to working from home most of the time.
 
Last edited:
Soldato
Joined
18 Oct 2002
Posts
11,587
Location
Birmingham
@GravyMonster - The 991.1 uses the same DFI engine (pretty much) as the later 997.2 and doesn’t suffer with score and doesn’t have an IMS. My understanding is that they’re pretty reliable units.

Servicing at a Porsche independent hasn’t proven particularly costly for me and I’ve had a very good experience with Zuffenhaus.

The 991.2 is a fantastic machine and if you’re looking at servicing it at an independent and taking it out of the Porsche warranty and main dealer network, a Litchfield remap would be high on my agenda!

The Porsche warranty is however a very good reason for keeping a main dealer service history.

All in all I’ve loved my 911 ownership, and I’m sure the later cars dial up the experience even more.
 
Soldato
Joined
29 Jul 2004
Posts
9,611
Location
Somerset
As @tom_nieto says 991 doesn't have the IMS/RMS issues. I would say a 991.1 in 3.8 flavour is a great buy and probably won't cost you much more overall. Personally I find the level of service and cover of OPC warranty worth it. PCP is indeed a crapshoot at the moment but that's true of all cars and arguably Porsche will have the most confident values anyway. Could you get that equity out of the E400 via a private sale / WBAC etc. and top it up with a personal loan? I would take a .1 with the 3.8 over a .2 3.0T aswell.
 
OcUK Staff
OP
Joined
17 Oct 2002
Posts
36,084
Location
OcUK HQ
Hi there

OK so this morning the Spyder started to play up again, dash flickering, power cutting in and out. So I quickly got the multimeter on the battery and engine running it was just 12-13v, so no charge been added, turned off and re-started the car and lots of errors and now 15v hitting the battery. Parked the car up and turned it off before it blew any more bulbs.

So the battery is now ruled out.
I guess the next stop is change the voltage regulator on the alternator. Can anyone help with a link for where I can buy a voltage regulator please as Porsche just want to sell a full alternator.

Car is a 2010 but 2011 model year 987.2 Boxster Spyder 3.4l DFI with 320HP.
 
Last edited:
OcUK Staff
OP
Joined
17 Oct 2002
Posts
36,084
Location
OcUK HQ
Build dates fit!

Ordered from Frazerpart, more expensive at £75 delivered but guaranteed delivery by weekend, I've ordered from AutoDoc before and its very hit or miss on delivery time, sometimes a few days other times couple of weeks.

P.S. Found on Amazon in stock under £30 delivered! :)
 
OcUK Staff
OP
Joined
17 Oct 2002
Posts
36,084
Location
OcUK HQ
Got the alternator out, bit of effort squeezing it out of the access panel without dropping the engine, but other than that the job went pretty smooth and easy.
Unfortunately the replacement voltage regulator is not correct, got another one coming tomorrow so fingers crossed that is right.

Not looking forward to trying to get the alternator to fit back through the hole, might need some persuasion lol.
 
Soldato
Joined
5 Nov 2010
Posts
22,610
Got the alternator out, bit of effort squeezing it out of the access panel without dropping the engine, but other than that the job went pretty smooth and easy.
Unfortunately the replacement voltage regulator is not correct, got another one coming tomorrow so fingers crossed that is right.

Not looking forward to trying to get the alternator to fit back through the hole, might need some persuasion lol.

Ah that sucks. Always annoying to have to faff around to replace something only to find the part is wrong!

Get your better half to help, smaller hands and all. Failing that, a mallet?
 
OcUK Staff
OP
Joined
17 Oct 2002
Posts
36,084
Location
OcUK HQ
Hi there

So I got the alternator refitted, rock stable 14.80v car running, 12.6v without running, so job done correctly.

Took the car to Wales, bit of a gamble really as generally when I've worked on a car I keep to short journeys until I am sure I solved the issue, but I took the gamble and it did not pay off.

Car was driving absolutely fine, zero signs or issues for about 50-60 miles, parked up for some breakfast, got back in the car and as I booted it off a roundabout I heard the car backfire and I noticed from the dash flickering it had lost power, but that was it the remainder of the drive was trouble free.

Heading up to the Horse Shoe pass viewing point no issues, great twisty roads, all was well, parked the car up to check the views, get some photos:


P9.jpg

P8.jpg

P6.jpg





So jumped back in the car, key in dash lit up and then dead, zero power at all to anything. Like the battery was totally flat. Now I had a spare battery, mobile jump starter and all the tools required in the front boot, but alas with zero power I could not pop the frunk. Should of put the small mobile jump starter battery in the cabin (we live and learn), anyway rang RAC who would be with me in 1-2hr, asked a few cars parked up if they had a jump kit or jump leads, thankfully a couple of lads in a van had jump leads, so they pulled the van as close as they could get and I put the jump leads on the fuse box emergency power connector and then negative to ground (door hinge) and left it connected for a couple of minutes at which point the car released the key and the dash had power and I was able to open the frunk.

So I immediately checked the battery with multi meter which was showing 12.60v so the battery had full power. So I started to check everything and everything was tight.
Then one of the guys said what is that on your battery, to which I was like actually I've no idea as its not fused and it was there when I purchased the car. So we started to undo it and the car all of a sudden got power and then cut out again.

Needless to say the fault seems far more simple than we could ever have imagined and appears to be basically some form of quick disconnect, as such I removed this on the spot, tried not to be too embarrassed at the thought of over looking something so simple and spending all that time removing the alternator and fitting a new regulator just to refit it all when it appears the issue was been caused by something so simple that only took two minutes to remove and only required the use of an 11mm spanner.


The offending item:

P10.jpg





As such Spyder ownership is awesome again, was able to proceed to the beach and had an awesome drive there, great time at the beach and awesome drive home.


Glad I've finally sorted it and yes I kicked myself for over looking what was such a simple thing.
 
Last edited:
Soldato
Joined
17 Nov 2007
Posts
2,681
I saw one of those at Brands last week, bloke had it fitted to his range rover.

Thats an eBay quick isolator, enables you to just undo a little or remove it and it disconnects the battery to stop it draining, people use them on cars not being used a lot.

When its screwed down tight it should create a decent connection.
 
Soldato
Joined
21 Jan 2010
Posts
12,708
:cry: nightmare! Thank god for finding it. Could have started throwing serious bills trying to chase something so silly down.
 
OcUK Staff
OP
Joined
17 Oct 2002
Posts
36,084
Location
OcUK HQ
I saw one of those at Brands last week, bloke had it fitted to his range rover.

Thats an eBay quick isolator, enables you to just undo a little or remove it and it disconnects the battery to stop it draining, people use them on cars not being used a lot.

When its screwed down tight it should create a decent connection.


Yep is the problem buying used, as such it came with the car and I never paid much attention too it, however maybe it was faulty or going that way because it was when it was undone slightly the car got power back, either way its now in the bin, good riddance to it, lol. :D
 

DRZ

DRZ

Soldato
Joined
2 Jun 2003
Posts
7,160
Location
In the top 1%
I’m willing to bet that they fitted it because either they hardly used the car (possibly, but why not buy a ctek instead…) or because they knew there was an electrical charging or drain issue somewhere and either didn’t want to or couldn’t afford to fix it properly. You see little bodges like that all the time on cars that can potentially have mystery battery drains.

Glad you found it anyway and got to enjoy the Welsh roads. I did a fair few miles in North Wales myself over the weekend. Glorious weather and loads of bikes and speed cops out as a result.
 
Caporegime
Joined
23 Dec 2011
Posts
29,881
Location
Northern England
Lol silly Gibbo. Lesson learned and certainly not something you'd think of if you weren't expecting it. Glad it didn't shaft you too much on the day though.
 
Top Bottom